Sysop:Wordpress

Aus immerda
Version vom 24. Januar 2014, 22:09 Uhr von Muri (Diskussion | Beiträge) (Muri verschob Seite Wordpress nach Sysop:Wordpress, ohne dabei eine Weiterleitung anzulegen: articles referring to sysop stuff should be in the sysop namespace)
(Unterschied) ← Nächstältere Version | Aktuelle Version (Unterschied) | Nächstjüngere Version → (Unterschied)
Zur Navigation springen Zur Suche springen

Mass Install/Upgrade WordPress with Gentoo+Webapp_config

Scripts for a WordPress Weblog Farm

Example script:

#!/bin/bash
# Wordpress mass upgrade script
# by immerda project group 
# admin(at)immerda.ch
# script unter GPLv3

home_dir=foobar1
backup_dir=foobar2
latest=`ls /usr/share/webapps/wordpress/ | tail`
for dir in [ "blog1" "blog2" "blogX" ]
do
    if [ -f $home_dir/$dir/www/.webapp-wordpress-* ]
    then
        cp -a $home_dir/$dir $backup_dir
        sitename=`basename $dir`
        webapp-config -U -h $sitename -d / wordpress $latest
        curl http://$sitename/wp-admin/upgrade.php?step=1 > /dev/null
        CONFIG_PROTECT="$home_dir/$dir/www/" etc-update
    fi
done

Mod_Security

sysop:Mod_Security can be used to take attackers and spammers away.

An additional rule set you can find on gotroot:

There is also a paper which describes how to install mod_security for wordpress:

mod_security problem

If you’re getting an apache error that says “You don’t have permission to access /wp-admin/options.php on this server.”, this is most likely your problem.

The solution is to add this to your exclusions.conf file:

<LocationMatch "/wp-admin/options.php">
      SecFilterRemove 300015
</LocationMatch>